Das Problem

Ich habe einen älteren PC, dem seit Erscheinen von Windows 10 dieses Betriebssystem und die entsprechenden Anwendungen aufgespielt wurden, und der permanent über Windows-Update aktualisiert wurde. Somit hat er mittlerweile ohne eine Neuinstallation den Schritt von der Windows-Version 18xx auf 2004 geschafft 🙂

Bisher hat sich nie die Notwendigkeit ergeben, ihn neu aufzusetzen, er ist flott und funktioniert, also “never change a running System”.

Seit etwa einer Woche nervt das System mit der Meldung “Kein Internetzugriff”, obwohl alles tadellos funktioniert. Man sowohl im Browser surfen, als auch via (S)FTP Dateien hoch- und herunterladen.

Im Netz findet man auf gefühlt tausend Seiten den Tipp, man möge in der Registry unter dem Schlüssel Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet den Parameter “EnableActiveProbing” auf “1” setzen.


Anzeige *

* Solltet ihr über diese Links bei Amazon etwas kaufen, erhalten wir eine kleine Provision.


Die Lösung

Der Parameter EnableActiveProbing hatte bei mir aber bereits den richtigen Wert, also musste es eine andere Ursache haben. Ich habe lange rechercieren und suchen müssen, und bin dann auf die Idee gekommen, die Werte mit einem Laptop, der vor einigen Wochen frisch mit Windows 10 Version 2004 aufgesetzt wurde, zu vergleichen. Und hier bin ich dann auch prompt fündig geworden.

Microsoft hat hier anscheinend die Adressen für die Checks geändert, diese Änderung wurde aber nicht automatisch auf dem alten Rechner nachgezogen. Schade eigentlich …

Nachdem ich die aktuellen Werte auf dem alten PC eingepflegt habe, funktionierte der Check wieder tadellos, und im Netzwerkstatus wurde wieder eine Verbindung angezeigt 🙂

Die aktuellen Werte sind auf dem Bild oben zu sehen, oder hier nochmals explizit in der folgenden Tabelle, damit ihr sie mit Copy & Paste übernehmen könnt:

ActiveDnsProbeContent131.107.255.255
ActiveDnsProbeHostdns.msftncsi.com
ActiveWebProbeContentMicrosoft Connect Test
ActiveWebProbeHostwww.msftconnecttest.com
ActiveWebProbePathconnecttest.txt
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet

Bedenkt aber bitte, daß ich diesen Beitrag im Oktober 2020 geschrieben habe, und wenn ihr ihn erst in einigen Monaten findet, könnte Microsoft schon wieder etwas verändert haben.
Ihr braucht dann einfach nur einen relativ frisch installieren Rechner, und könnt dort die relevanten Registy-Einträge nachschauen. Das System hat sich ja nicht verändert, nur die Inhalte 🙂

Wenn wir Kenntnis über Änderungen erhalten, werden wir das natürlich in diesem Beitrag nachpflegen.

Update 08.11.2020

Bei einem älteren Windows-7 Computer stellte sich heute das gleiche Problem dar. Es ließ sich aber genauso lösen, wie ich es oben für Windows 10 beschrieben habe.

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Ich habe die Datenschutzerklärung gelesen und akzeptiert und stimme der Datenspeicherung gem. DSGVO zu.